VNC Viewer Chat functionality can cause the remote computer to become uncontrollable
Incident Report for RealVNC
Resolved
This incident has been resolved.
Posted Nov 24, 2021 - 15:53 UTC
Update
A new version of the VNC Viewer (6.21.1109) has been released to fix the chat bug.
Posted Nov 24, 2021 - 15:52 UTC
Update
A fix has been implemented and we'll be rolling out the updated viewer shortly. Please keep an eye on our release notes (https://help.realvnc.com/hc/en-us/articles/360002253138-Release-Notes) for further information.
Posted Nov 23, 2021 - 10:12 UTC
Identified
The issue has been identified and a fix is being worked on
Posted Nov 08, 2021 - 15:50 UTC
Investigating
We are aware of an issue with VNC Viewer 6.21.920 that using the Chat feature may block control of the remote computer. To restore control of your remote access session, click Options on the VNC Viewer toolbar at the top of the screen and disable the EnableChat parameter in the Expert tab. This will allow you to control the remote computer again. Once control is restored, ensure you close the Server chat window.
NOTE: the user you are chatting with can close or de-focus the chat window at any time to restore viewer control.

We are working on an updated version of VNC Viewer as a priority.

For now we recommend not using the Chat functionality, or disabling Chat by setting EnableChat to False (in the VNC Server Expert tab).
Posted Nov 08, 2021 - 15:49 UTC