Possible issue when updating payment cards on the VNC Connect portal
Incident Report for RealVNC
Resolved
This issue has been resolved by our payment processor.
Posted Nov 25, 2021 - 22:25 UTC
Update
We are continuing to investigate this issue.
Posted Nov 25, 2021 - 16:13 UTC
Investigating
Our payment processor is experiencing some issues with updating payment cards and some customers may experience problems when adding new payment cards on the Billing page of the VNC Connect portal. If you experience this, please try again later.
Posted Nov 25, 2021 - 16:13 UTC