Our regional network provider are continuing to work on a resolution to the issue.
Posted Oct 08, 2022 - 14:05 UTC
Investigating
We are currently investigating an issue with one of our transit network providers. This incident might cause some customers to experience higher than normal latency.
Posted Oct 08, 2022 - 06:13 UTC
This incident affected: RealVNC Connect (Connectivity Service).