Issue with completing purchases
Incident Report for RealVNC
Resolved
We have set this issue to resolved. We will be applying the fix to affected accounts over the next few days. If you experience an issue with completing a purchase please contact support.
Posted 8 months ago. Oct 11, 2018 - 15:30 UTC
Update
The issue appears only to be affecting customers who had previously requested RealVNC customer services to merge accounts. If you have asked us previously to merge accounts and receive the message "'We're tracking this problem automatically, but if it persists do let us know. In the meantime, you could check our status page, or try reloading the page." when trying to purchase or renew your VNC Connect subscription, please contact our support team.
Posted 8 months ago. Oct 11, 2018 - 15:17 UTC
Investigating
We are aware that some customers may be experiencing an issue with completing purchases. We are investigating this issue. We apologise for the inconvenience. Please check back here for updates.
Posted 8 months ago. Oct 11, 2018 - 14:56 UTC
This incident affected: VNC Connect (Website).